Mengatasi Masalah The Itemprop Atribut Was Specified Pada Saat Memvalidasi HTML Blog di W3.org



The Itemprop Atribut Was Specified, But The Element Is Not a Property Of Any Item, pesan kesalahan HTML yang saya jumpai pada saat saya memvalidasi HTML di w3.org, dan beberapa lama setelah saya cari solusi untuk masalah ini digoogle, akhirnya saya menemukan solusinya di suatu Forum google, tapi solusi yang diberikan masih kurang ampuh, tapi saya sudah merubah sedikit, akhirnya pesan error The Itemprop Atribut Was Specified, But The Element Is Not a Property Of Any Item sudah teratasi.

Berikut cara mengatasinya


  • Edit Template Blog anda.
  • Cari Tag <body>
  • Masukkan ke Tag Body text ini itemscope=" " itemtype="http://schema.org/WebPage"
  • Sehingga menjadi  <body itemscope=" " itemtype="http://schema.org/WebPage">
  • Kemudian simpan dan Check sekali lagi Validasinya


    Bandingkan Blog saya sebelum dan sesudah saya mengaplikasikan cara tersebut

(sebelum)

(sesudah)

Pada Blog saya, terlihat ada 21 error pada gambar (sesudah), error tesebut adalah
& did not start a character reference. (& probably should have been escaped as &amp;.)
yang terletak pada 
…post-edit.g?blogID=3615354377846373536&postID=1443815124517115491&from=pencil'…
dan
…3615354377846373536&postID=1443815124517115491&from=pencil' title='Edit Entri'>

Setelah saya baca artikel http://blog.kangismet.net/2013/08/cara-membuat-blog-valid-html5.html dan saya terapkan di blog saya ternyata errornya hilang, dan template blog saya sudah valid



Sekian dulu Artikel saya ini, mudah-mudahan bisa bermamfaat bagi pembaca.

0 Response to "Mengatasi Masalah The Itemprop Atribut Was Specified Pada Saat Memvalidasi HTML Blog di W3.org"

Post a Comment